You are here: Office-Outlook.com  / Outlook Forum

Foreign language characters

Home » General Outlook opportunities » Outlook
Foreign language characters [message #300361] Tue, 13 May 2008 14:33 Go to next message
8twr
Messages: 7
Registered: January 2008
Junior Member
I receive emails from a Korean customer that have a mix of English and Korean
characters, and question marks between sentences. I am using Windows 2000
(SP4) with Outlook 2003 (SP3), at "Tools", "Options", settings are;
International Options, Encoding Options - Auto Select Encoding On, Preferred
Encoding - set at Western European (Windows). I have tried several settings
with the same result - any ideas?
Re: Foreign language characters [message #300390] Tue, 13 May 2008 15:52 Go to previous messageGo to next message
8twr
Messages: 7
Registered: January 2008
Junior Member
Using UNICODE.

"Roady [MVP]" wrote:

> Are you using a UNICODE formatted pst-file?
> See http://www.msoutlook.info/question/111
>
> --
> Robert Sparnaaij [MVP-Outlook]
> Coauthor, Configuring Microsoft Outlook 2003
> http://www.howto-outlook.com/
> Outlook FAQ, HowTo, Downloads, Add-Ins and more
>
> http://www.msoutlook.info/
> Real World Questions, Real World Answers
>
> -----
>
> "8twr" <8twr@discussions.microsoft.com> wrote in message
> news:0447FC2B-80CC-4C2D-8BB0-4FB6B7E19FD3@microsoft.com...
> > I receive emails from a Korean customer that have a mix of English and
> > Korean
> > characters, and question marks between sentences. I am using Windows 2000
> > (SP4) with Outlook 2003 (SP3), at "Tools", "Options", settings are;
> > International Options, Encoding Options - Auto Select Encoding On,
> > Preferred
> > Encoding - set at Western European (Windows). I have tried several
> > settings
> > with the same result - any ideas?
> >
Re: Foreign language characters [message #300730] Wed, 14 May 2008 13:52 Go to previous messageGo to next message
8twr
Messages: 7
Registered: January 2008
Junior Member
The incoming message is encoded "Korean (Auto-Select), plain text.


"Pat Willener" wrote:

> What is the encoding of the incoming messages. Also, what message types
> (HTML or plain text)?
>
> 8twr wrote:
> > I receive emails from a Korean customer that have a mix of English and Korean
> > characters, and question marks between sentences. I am using Windows 2000
> > (SP4) with Outlook 2003 (SP3), at "Tools", "Options", settings are;
> > International Options, Encoding Options - Auto Select Encoding On, Preferred
> > Encoding - set at Western European (Windows). I have tried several settings
> > with the same result - any ideas?
>
Re: Foreign language characters [message #300899] Thu, 15 May 2008 00:08 Go to previous messageGo to next message
Pat Willener
Messages: 2570
Registered: July 2006
Senior Member
Check the message headers (View -> Options -> Internet headers) what the
actual encoding is (Content-Type:text/plain; charset= ).

8twr wrote:
> The incoming message is encoded "Korean (Auto-Select), plain text.
>
>
> "Pat Willener" wrote:
>
>> What is the encoding of the incoming messages. Also, what message types
>> (HTML or plain text)?
>>
>> 8twr wrote:
>>> I receive emails from a Korean customer that have a mix of English and Korean
>>> characters, and question marks between sentences. I am using Windows 2000
>>> (SP4) with Outlook 2003 (SP3), at "Tools", "Options", settings are;
>>> International Options, Encoding Options - Auto Select Encoding On, Preferred
>>> Encoding - set at Western European (Windows). I have tried several settings
>>> with the same result - any ideas?
Re: Foreign language characters [message #301047] Thu, 15 May 2008 10:50 Go to previous messageGo to next message
8twr
Messages: 7
Registered: January 2008
Junior Member
This is what it shows:

Content-Type: multipart/alternative;
boundary="----_=_NextPart_001_01C8B48E.07327F13"

"Pat Willener" wrote:

> Check the message headers (View -> Options -> Internet headers) what the
> actual encoding is (Content-Type:text/plain; charset= ).
>
> 8twr wrote:
> > The incoming message is encoded "Korean (Auto-Select), plain text.
> >
> >
> > "Pat Willener" wrote:
> >
> >> What is the encoding of the incoming messages. Also, what message types
> >> (HTML or plain text)?
> >>
> >> 8twr wrote:
> >>> I receive emails from a Korean customer that have a mix of English and Korean
> >>> characters, and question marks between sentences. I am using Windows 2000
> >>> (SP4) with Outlook 2003 (SP3), at "Tools", "Options", settings are;
> >>> International Options, Encoding Options - Auto Select Encoding On, Preferred
> >>> Encoding - set at Western European (Windows). I have tried several settings
> >>> with the same result - any ideas?
>
Re: Foreign language characters [message #301159] Thu, 15 May 2008 14:09 Go to previous messageGo to next message
Brian Tillman
Messages: 25117
Registered: June 2006
Senior Member
8twr <8twr@discussions.microsoft.com> wrote:

> This is what it shows:
>
> Content-Type: multipart/alternative;
> boundary="----_=_NextPart_001_01C8B48E.07327F13"

There should be other Content-Type headers as well. One of those should
have the charset value on it.
--
Brian Tillman [MVP-Outlook]
Re: Foreign language characters [message #301242] Thu, 15 May 2008 17:27 Go to previous messageGo to next message
8twr
Messages: 7
Registered: January 2008
Junior Member
Brian,

This is everything in the Internet Headers - I don't see charset listed:

Return-path: <krlee@koreanair.com>
Envelope-to: terry@dascoeng.com
Delivery-date: Mon, 12 May 2008 20:10:22 -0400
Received: from impinc03.yourhostingaccount.com ([10.1.13.103]
helo=impinc03.yourhostingaccount.com)
by mailscan12.yourhostingaccount.com with esmtp (Exim)
id 1Jvi62-0003Cq-MK
for terry@dascoeng.com; Mon, 12 May 2008 20:10:22 -0400
Received: from selexfe032.hanjingroup.net ([59.15.10.3])
by impinc03.yourhostingaccount.com with NO UCE
id QoAL1Z05c03w48T03oAMra; Mon, 12 May 2008 20:10:22 -0400
X-EN-OrigIP: 59.15.10.3
X-EN-IMPSID: QoAL1Z05c03w48T03oAMra
Received: from KESELMBX002.hanjingroup.net ([10.100.151.35]) by
selexfe032.hanjingroup.net with Microsoft SMTPSVC(6.0.3790.1830); Tue, 13 May
2008 09:12:15 +0900
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2992
Content-class: urn:content-classes:message
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----_=_NextPart_001_01C8B48E.07327F13"
Subject: RE: Remittance Advice From Korean Air
Date: Tue, 13 May 2008 09:10:17 +0900
Message-ID:
<B7CD98B924CBD941A8798D7A4258306BCFF35F@KESELMBX002.hanjingroup.net>
Content-Transfer-Encoding: 7bit
In-Reply-To:
<B7CD98B924CBD941A8798D7A4258306B1793BC@KESELMBX002.hanjingroup.net>
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
Thread-Topic: Remittance Advice From Korean Air
Thread-Index: Aciei3dYFbjtPDfxSBiHX2NnrAlb2ATWQKRwABIWQGAAmC+dUA==
From: "LEE KWANG RO" <krlee@koreanair.com>
To: =?ks_c_5601-1987?B?x9Swx8HWKFBQQixIQUhNIEtVTiBKT08p?=
<kjhahm@koreanair.com>
Cc: <terry@dascoeng.com>
Importance: normal
Priority: normal
X-OriginalArrivalTime: 13 May 2008 00:12:15.0560 (UTC)
FILETIME=[FFD50C80:01C8B48D]

"Brian Tillman" wrote:

> 8twr <8twr@discussions.microsoft.com> wrote:
>
> > This is what it shows:
> >
> > Content-Type: multipart/alternative;
> > boundary="----_=_NextPart_001_01C8B48E.07327F13"
>
> There should be other Content-Type headers as well. One of those should
> have the charset value on it.
> --
> Brian Tillman [MVP-Outlook]
>
>
Re: Foreign language characters [message #301290] Thu, 15 May 2008 23:36 Go to previous messageGo to next message
Pat Willener
Messages: 2570
Registered: July 2006
Senior Member
That explains it; the sender did not specify any Korean encoding, such
as 'iso-2022-kr'. It is the sender's responsibility to specify the
correct encoding. Once you have received it with broken multibyte
characters, there is not much you can do to retrieve the unbroken code.

You can try to edit the message, then specify the Korean encoding, but
it is unlikely that it will actually fix the broken characters.

8twr wrote:
> Brian,
>
> This is everything in the Internet Headers - I don't see charset listed:
>
> Return-path: <krlee@koreanair.com>
> Envelope-to: terry@dascoeng.com
> Delivery-date: Mon, 12 May 2008 20:10:22 -0400
> Received: from impinc03.yourhostingaccount.com ([10.1.13.103]
> helo=impinc03.yourhostingaccount.com)
> by mailscan12.yourhostingaccount.com with esmtp (Exim)
> id 1Jvi62-0003Cq-MK
> for terry@dascoeng.com; Mon, 12 May 2008 20:10:22 -0400
> Received: from selexfe032.hanjingroup.net ([59.15.10.3])
> by impinc03.yourhostingaccount.com with NO UCE
> id QoAL1Z05c03w48T03oAMra; Mon, 12 May 2008 20:10:22 -0400
> X-EN-OrigIP: 59.15.10.3
> X-EN-IMPSID: QoAL1Z05c03w48T03oAMra
> Received: from KESELMBX002.hanjingroup.net ([10.100.151.35]) by
> selexfe032.hanjingroup.net with Microsoft SMTPSVC(6.0.3790.1830); Tue, 13 May
> 2008 09:12:15 +0900
> X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2992
> Content-class: urn:content-classes:message
> MIME-Version: 1.0
> Content-Type: multipart/alternative;
> boundary="----_=_NextPart_001_01C8B48E.07327F13"
> Subject: RE: Remittance Advice From Korean Air
> Date: Tue, 13 May 2008 09:10:17 +0900
> Message-ID:
> <B7CD98B924CBD941A8798D7A4258306BCFF35F@KESELMBX002.hanjingroup.net>
> Content-Transfer-Encoding: 7bit
> In-Reply-To:
> <B7CD98B924CBD941A8798D7A4258306B1793BC@KESELMBX002.hanjingroup.net>
> X-MS-Has-Attach:
> X-MS-TNEF-Correlator:
> Thread-Topic: Remittance Advice From Korean Air
> Thread-Index: Aciei3dYFbjtPDfxSBiHX2NnrAlb2ATWQKRwABIWQGAAmC+dUA==
> From: "LEE KWANG RO" <krlee@koreanair.com>
> To: =?ks_c_5601-1987?B?x9Swx8HWKFBQQixIQUhNIEtVTiBKT08p?=
> <kjhahm@koreanair.com>
> Cc: <terry@dascoeng.com>
> Importance: normal
> Priority: normal
> X-OriginalArrivalTime: 13 May 2008 00:12:15.0560 (UTC)
> FILETIME=[FFD50C80:01C8B48D]
>
> "Brian Tillman" wrote:
>
>> 8twr <8twr@discussions.microsoft.com> wrote:
>>
>>> This is what it shows:
>>>
>>> Content-Type: multipart/alternative;
>>> boundary="----_=_NextPart_001_01C8B48E.07327F13"
>> There should be other Content-Type headers as well. One of those should
>> have the charset value on it.
>> --
>> Brian Tillman [MVP-Outlook]
Re: Foreign language characters [message #305949] Tue, 20 May 2008 15:59 Go to previous message
8twr
Messages: 7
Registered: January 2008
Junior Member
I didn't mention it before, but a colleague receives a copy of the same
message and it comes through clean. Does this mean he has a different
version of Outlook, or has different settings?

"Pat Willener" wrote:

> That explains it; the sender did not specify any Korean encoding, such
> as 'iso-2022-kr'. It is the sender's responsibility to specify the
> correct encoding. Once you have received it with broken multibyte
> characters, there is not much you can do to retrieve the unbroken code.
>
> You can try to edit the message, then specify the Korean encoding, but
> it is unlikely that it will actually fix the broken characters.
>
> 8twr wrote:
> > Brian,
> >
> > This is everything in the Internet Headers - I don't see charset listed:
> >
> > Return-path: <krlee@koreanair.com>
> > Envelope-to: terry@dascoeng.com
> > Delivery-date: Mon, 12 May 2008 20:10:22 -0400
> > Received: from impinc03.yourhostingaccount.com ([10.1.13.103]
> > helo=impinc03.yourhostingaccount.com)
> > by mailscan12.yourhostingaccount.com with esmtp (Exim)
> > id 1Jvi62-0003Cq-MK
> > for terry@dascoeng.com; Mon, 12 May 2008 20:10:22 -0400
> > Received: from selexfe032.hanjingroup.net ([59.15.10.3])
> > by impinc03.yourhostingaccount.com with NO UCE
> > id QoAL1Z05c03w48T03oAMra; Mon, 12 May 2008 20:10:22 -0400
> > X-EN-OrigIP: 59.15.10.3
> > X-EN-IMPSID: QoAL1Z05c03w48T03oAMra
> > Received: from KESELMBX002.hanjingroup.net ([10.100.151.35]) by
> > selexfe032.hanjingroup.net with Microsoft SMTPSVC(6.0.3790.1830); Tue, 13 May
> > 2008 09:12:15 +0900
> > X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2992
> > Content-class: urn:content-classes:message
> > MIME-Version: 1.0
> > Content-Type: multipart/alternative;
> > boundary="----_=_NextPart_001_01C8B48E.07327F13"
> > Subject: RE: Remittance Advice From Korean Air
> > Date: Tue, 13 May 2008 09:10:17 +0900
> > Message-ID:
> > <B7CD98B924CBD941A8798D7A4258306BCFF35F@KESELMBX002.hanjingroup.net>
> > Content-Transfer-Encoding: 7bit
> > In-Reply-To:
> > <B7CD98B924CBD941A8798D7A4258306B1793BC@KESELMBX002.hanjingroup.net>
> > X-MS-Has-Attach:
> > X-MS-TNEF-Correlator:
> > Thread-Topic: Remittance Advice From Korean Air
> > Thread-Index: Aciei3dYFbjtPDfxSBiHX2NnrAlb2ATWQKRwABIWQGAAmC+dUA==
> > From: "LEE KWANG RO" <krlee@koreanair.com>
> > To: =?ks_c_5601-1987?B?x9Swx8HWKFBQQixIQUhNIEtVTiBKT08p?=
> > <kjhahm@koreanair.com>
> > Cc: <terry@dascoeng.com>
> > Importance: normal
> > Priority: normal
> > X-OriginalArrivalTime: 13 May 2008 00:12:15.0560 (UTC)
> > FILETIME=[FFD50C80:01C8B48D]
> >
> > "Brian Tillman" wrote:
> >
> >> 8twr <8twr@discussions.microsoft.com> wrote:
> >>
> >>> This is what it shows:
> >>>
> >>> Content-Type: multipart/alternative;
> >>> boundary="----_=_NextPart_001_01C8B48E.07327F13"
> >> There should be other Content-Type headers as well. One of those should
> >> have the charset value on it.
> >> --
> >> Brian Tillman [MVP-Outlook]
>
Previous Topic:RE: email signature with company logo or scanned signature
Next Topic:Auto populate in "To" field when creating new message not working
Goto Forum: